¿Hay programa incompatibles?

Utilice este foro para realizar propuestas de aplicaciones que le gustaría ver incorporadas a MAX a través de la página +Aplicaciones

Moderadores: dgonzalezarroyo, ismagago, ezequiel, jrodriguezpascua

Responder
fmartinez
Mensajes: 8
Registrado: 11 Oct 2019, 18:35

¿Hay programa incompatibles?

Mensaje por fmartinez »

Hola,

Me gustaría instalar en MAX un par de programas: Brackets (un editor de páginas webs) y OBS Studio (para capturar pantalla y webcam).

El tema es que para instalar ambos estoy escribiendo desde consola:

Código: Seleccionar todo

sudo apt-get install brackets

Código: Seleccionar todo

sudo apt-get install obs-studio
Mi problema es que cuando instalo obs-studio, me desinstala brackets, y cuando vuelvo a instalar brackets me desinstala obs-studio.

¿Que está pasando?¿Son incompatibles?

Muchas gracias!
Fernando

dgonzalezarroyo
Mensajes: 1218
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ¿Hay programa incompatibles?

Mensaje por dgonzalezarroyo »

Hola

Podría haber algún problema con las dependencias de uno y otro. Yo te aconsejo que utilices MAX 10 actualizado a tope. Si sigue apareciendo el problema, prueba a instalar brackets como aplicación snap. Lo tienes explicado en la primera parte de este artículo --> https://itsfoss.com/install-brackets-ubuntu/

A ver si así...

Un saludo
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo

fmartinez
Mensajes: 8
Registrado: 11 Oct 2019, 18:35

Re: ¿Hay programa incompatibles?

Mensaje por fmartinez »

Creo que tengo MAX 10 a tope de actualizaciones, no sé que más hacer a parte de un update y un upgrade.

He probado lo del snap, pero cuando sigo el tutorial que me has pasado me da el siguiente error:

error: Esta revisión del snap "brackets" se publicó usando el confinamiento clásico por lo cual podría realizar cambios arbitrarios del sistema fuera de la caja de seguridad en el que los snaps suelen estar confinados, lo cual podría suponer un riesgo para su sistema.
Si lo entiende y desea continuar repita la orden incluyen --classic.

No se si esto me pasa solo a mi o si alguien lo puede replicar (digo lo de instalar Brackets y OBS Studio a la vez).

Muchas gracias por tu ayuda

dgonzalezarroyo
Mensajes: 1218
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ¿Hay programa incompatibles?

Mensaje por dgonzalezarroyo »

Hola

En este ordenador no puedo reproducir el problema. Me aparece este error al tratar de instalar brackets
Los siguientes paquetes tienen dependencias incumplidas:
brackets : Depende: libcurl3 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
Pero yo no veo paquetes rotos...

De todos modos, también puedes probar a instalar el obs studio mediante snap https://snapcraft.io/install/obs-studio/ubuntu

E, incluso, probar a hacerlo en el modo "classic", si llegara el caso
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo

fmartinez
Mensajes: 8
Registrado: 11 Oct 2019, 18:35

Re: ¿Hay programa incompatibles?

Mensaje por fmartinez »

Hola David,
Ese error a mi también me daba, lo arreglé instalando manualmente la dependencia haciendo:

Código: Seleccionar todo

sudo apt-get install libcurl3
Probaré a instalar OBS Studio mediante snap.

De todas formas, también voy a mandar un correo al CAU de MAX, a ver si ellos dan con la tecla.

Muchas gracias de nuevo!

Responder