ordenador no arranca - GRUB - RESUELTO

Dudas sobre la instalación de MAX.

Moderadores: dgonzalezarroyo, ismagago, ezequiel, jrodriguezpascua

Responder
Manolo el del bombo
Mensajes: 73
Registrado: 19 Ene 2009, 21:20

ordenador no arranca - GRUB - RESUELTO

Mensaje por Manolo el del bombo »

Me ha ocurrido lo siguiente: Después de instalar MAX con éxito en un equipo, le he puesto a actualizar software. Al terminar, lo he apagado. Sin embargo, una hora más tarde me he percatado de que no apagaba y se había quedado "colgado" en una pantalla en la que aparecía el logo de MAX. Como no me parecía muy normal, lo he apagado con el botón del ordenador.
Al intentar encenderlo de nuevo, ahora lo que me aparece es esto (GRUB)
http://cloud.educa.madrid.org/index.php ... Z8UXji5JYW

Y de ahí ya sí que no sé salir.

Tampoco puedo acceder a la bios. Al intentarlo, me sale la siguiente pantalla:
http://cloud.educa.madrid.org/index.php ... kaNkJs9I8s

A partir de ahí, poco más puedo hacer porque no entiendo nada. Me da opciones de "enrol key" y "enrol hash" y si le doy ahí muestra los archivos que hay en el usb que tengo metido con el instalador, pero no sé si tendría que seleccionar algún archivo de ahi, o qué archivo en concreto.


Si alguien pudiese ayudarme la verdad es que se lo agradecería mucho.

-----------------CASI RESUELTO---------------------
Di con este vídeo en youtube que explica los comandos que tienes que ir metiendo para que vuelva a arrancar correctamente:
https://www.youtube.com/watch?v=eo9nN1v8Snw

SIN EMBARGO ** al encenderlo al día siguiente, vuelve al mismo punto de partida, y claro, vuelta a empezar.
Agradecería ayuda
Última edición por Manolo el del bombo el 27 Ene 2021, 09:30, editado 1 vez en total.
dgonzalezarroyo
Mensajes: 1448
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por dgonzalezarroyo »

Hola

Eso parece el error del GRUB que se resuelve con el "boot repair". Entra en modo live y lanza el bootrepair mediante este comando:

sudo boot-repair

Luego hay que seguir estas indicaciones:

* Al ejecutar el programa vamos a opciones avanzadas y ponemos estas opciones en sus pestañas -->
* Opciones principales: reinstalar grub, usar el archivo efi estándar y mostrar el menú de arranque 10 segundos
* Ubicaciones de Grub: lo dejamos como esté
* Opciones de Grub: sólo marcada Purgar Grub antes de reinstalarlo
* Otras opciones: todo marcado
* Al darle a Salir si nos pregunta si hacer copia de la configuración de Windows le decimos que NO

Aparecen órdenes en bootrepair que hay que ejecutar una a una en un terminal. Se copia la orden, se pega en el terminal y se ejecuta. Aparecen tres órdenes distintas. Hay que leer bien lo que te pone en la ventana.

Luego pulsas Forward y suele aparecer otra orden. Haces lo mismo y Forward. Y ya está.
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo
Manolo el del bombo
Mensajes: 73
Registrado: 19 Ene 2009, 21:20

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por Manolo el del bombo »

Gracias por la respuesta David.
Llegó hasta q abro el boot repair y marco las opciones q indicas.
Me abre la ventana con las tres órdenes q hay q ejecutar, pero cuando copio la primera, la pego y le doy q intro no hace nada. Como se supone que tiene que ejecutarla?
Si intento cerrar el terminal me sale un aviso de q hay alguna orden ejecutándose, y si pincho en "adelante" en la ventana con las órdenes, me sale otro aviso diciendo qcgrub todavía está instalado
Disculpa pero soy totalmente nuevo en MAX
Pego pantallazo:
https://photos.app.goo.gl/1chkEair1ZF2gbGD8
dgonzalezarroyo
Mensajes: 1448
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por dgonzalezarroyo »

Manolo el del bombo escribió: 25 Ene 2021, 13:47 Como se supone que tiene que ejecutarla?
Se ejecuta en un segundo terminal (en tu imagen sólo veo un terminal).
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo
Manolo el del bombo
Mensajes: 73
Registrado: 19 Ene 2009, 21:20

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por Manolo el del bombo »

Lo que hice fue que cuando me salió la ventana que sale al frente con las tres órdenes, fue abrir un terminal para pegarlas ahí y esa ventana es la que se ve de fondo. ¿Tendría que hacer algo distinto?
dgonzalezarroyo
Mensajes: 1448
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por dgonzalezarroyo »

Manolo el del bombo escribió: 26 Ene 2021, 10:35 Lo que hice fue que cuando me salió la ventana que sale al frente con las tres órdenes, fue abrir un terminal para pegarlas ahí y esa ventana es la que se ve de fondo. ¿Tendría que hacer algo distinto?
Hay que ejecutarlas en un terminal distinto al terminal desde el que lanzaste el sudo boot-repair. Lanzalas una detrás de otra, y si hubiera algún problema veremos en cual de ellas es.
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo
Manolo el del bombo
Mensajes: 73
Registrado: 19 Ene 2009, 21:20

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por Manolo el del bombo »

Efectivamente, al abrir y pegar las órdenes en terminales distintos, me las ha ido ejecutando.
Aquí un vídeo de lo que he ido haciendo:
http://cloud.educa.madrid.org/index.php ... wdeM78RtZh

Después de terminar, he apagado el ordenador. He sacado el pendrive y he encendido el ordenador otra vez, pero sigo teniendo el problema, y ahora me sale la siguiente pantalla y ni siquiera puedo arrancarlo si no es en modo live con el pendrive metido:
https://photos.app.goo.gl/vJn9r1AFTP8QEn6E9

¿Tengo que hacer algo más en la bios o algo así?
dgonzalezarroyo
Mensajes: 1448
Registrado: 07 Abr 2010, 10:42
Contactar:

Re: ordenador no arranca - GRUB - NO RESUELTO

Mensaje por dgonzalezarroyo »

Efectivamente, es un tema de bios. Prueba a desactivar el modo seguro en ella.
David González, Profesor de Tecnología

Imagen

http://social.educa.madrid.org/dgonzalezarroyo
Manolo el del bombo
Mensajes: 73
Registrado: 19 Ene 2009, 21:20

Re: ordenador no arranca - GRUB - RESUELTO

Mensaje por Manolo el del bombo »

Muchas gracias David por toda tu ayuda.
Efectivamente entre en la BIOS / security / secure boot menu y lo cambié a "disabled", y desde entonces me arranca sin problema el equipo.
La verdad es que todos los pasos que me has ido recomendando a mí no se me hubieran ocurrido en mil años! ;)
Responder